
1 

Seven Steps to Creating 
Accessible Documents 

 

 

Disability Access Services  



2 

 

 
(https://www.dor.ca.gov/Home/DAS) 

 

About Disability Access Services 

Disability Access Services (DAS) is a unit within the California Department 
of Rehabilitation (DOR). We provide technical assistance and 
informational guidance to promote the civil rights and equality for 
individuals with disabilities involving: 

• Employment 
• Reasonable Accommodation 
• Physical access of built environments 
• Access to private sector goods and services 
• Digital access of electronic and information technology 
• Access to government programs, services, and activities 

DAS Website

DAS Contact Information 

CA Department of Rehabilitation 
Disability Access Services 
721 Capitol Mall, 4th Floor 
Sacramento, CA 95814  

Email: DASinfo@dor.ca.gov
Phone: (916) 558-5755 
Fax: (916) 558-5757 
TTY: 844-729-2800 
Telecommunications Relay Service 711  

https://www.dor.ca.gov/Home/DAS
mailto:DASinfo@dor.ca.gov
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Introduction 

It is a best practice to create accessible documents. Accessible 
documents allow anyone to read and navigate content, with or without 
assistive technology. According to the World Health Organization, over 
2.5 billion people need one or more assistive technology products 
(https://www.who.int/news-room/fact-sheets/detail/assistive-technology). 

In this document, we outline seven steps to create accessible documents. 
If you have any challenges navigating this document, please contact us. 

Alternative Formats 

This document can be made available in braille and large font as a 
reasonable accommodation. To request an alternative format, contact 
Disability Access Services. 

Hyperlinks in This Document 

Links are created with meaningful text. The Uniform Resource Locators 
(URLs) are included for print purposes and are not active. 

Disclaimer 

This document provides guidance and awareness on how to create 
accessible documents. It is not meant as a determination of your 
organization’s legal rights and responsibilities.  

https://www.who.int/news-room/fact-sheets/detail/assistive-technology
mailto:dasinfo@dor.ca.gov
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Step One: Use Appropriate Font Style and Size 

Font Style 

Not all fonts are created equal. Screens with low resolution can make 
certain fonts more difficult to see. Generally, sans serif fonts work best. 
The font styles listed below are recommended. 

• Arial 
• Verdana 

Font Size 

General Correspondence 

The minimum font size is 12 points for general correspondence. The 
minimum size can still be too small for some readers. Therefore, be 
prepared to provide content in large print or allow readers to adjust the 
font size. 

PowerPoint 

The minimum font size is 24 points for PowerPoint. Depending on room 
configuration and size, a larger font size may be better for readability.  
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Step 2: Appropriate Use of Color 

Never Use Color Alone to Convey Information 

Color should not be the only way to communicate information. When using 
colors, provide an alternative method so readers understand the 
information. 

For example, a table indicates the status of three projects. The first project 
has a green ‘X’ to indicate complete. The last two have a red ‘X’ to 
indicate not complete. 

 

 

This use of color may be considered a sufficient way of relaying 
information because most people assume green indicates positive and red 
negative. However, individuals who are colorblind and/or have low vision 
may have a hard time differentiating the colors. Persons from other 
cultural experiences may not identify the implied meaning of these colors. 

An alternative is to include another non-color dependent visual and/or 
symbol. For example, adding a letter. In the new table, the ‘X’ is replaced. 
A green ‘Y’ represents yes and red ‘N’ represents no. 

The same information is relayed—this time using both color and symbols. 
As a result, there is far less ambiguity about the project status.  
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Good Color Contrast 

Documents with low color contrast can be difficult or impossible for users 
to read. For this reason, text, images of text, and non-text content need to 
have a minimum color contrast. The required ratios are: 

• Regular size text: 4.5:1
(Text under 17 points is regular.)

• Large size text: 3:1
(Text 14 point bold or at least 18 point is 
large.)

• Non-text content: 3:1
(Visual information and icons.)
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Step Three: Alternative Texts and Wrapping Style 

Alternative Text for Images 

Images that sighted users can see should also be described to non-
sighted users. Alternative text, or alt text, is an effective way to 
communicate this information. Alt text provides the text equivalent 
description and allows readers to perceive the information without vision. 

To add alt text in Microsoft Office: 

1. Right click image. 
2. Go to View Alt Text. 
3. Type alt text in the field. 

Via Keyboard: Shift+Right Arrow, Shift+F10, A, type alternative text. 

 

It is acceptable to not add alternative text to decorative images. These 
images do not add value and can be Marked as Decorative in the Alt Text 
pane.  
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Alternative Text for Tables 

Alternative text can also be added to tables to detail additional content 
that would be useful for a user to know. This feature is optional and is 
available in Microsoft Word. To add alternative text: 

1. Right click table, select Table Properties. 
2. Navigate to Alt Text tab. 
3. Type in a Title and Description. 

Via Keyboard: Shift+F10, R until you get to Table Properties, press Enter, 
Alt+A, Tab to cycle through the Title, Description, and OK options. 
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Wrap Text 

Text wrapped around an image or graphic will confuse a screen reader. 
Always set the wrapping style of images to In Line with Text. This 
ensures the image is read in the correct order. 

1. Right click image. 
2. Select Wrap Text. 
3. Select In Line with Text. 

Via Keyboard: Shift+Right Arrow, Shift+F10, W, I. 

  



11 

Step Four: Meaningful Hyperlink Text  

Although phrases like, Click Here, or Visit, are commonly used as text for 
hyperlinks, they are not sufficient. Hyperlink text should clearly define the 
link destination.  

To create a meaningful hyperlink: 

1. Copy the URL. 
2. Identify the text you want to use for the link. 
3. Highlight the text, right click, and select Link. 
4. In the Insert Hyperlink dialogue box, notice: 

a. Text to Display: This is the text you highlighted. 
b. Address: Your focus will be on here already. Type or paste the 

link destination. 
5. Select Ok. 

Via Keyboard: Control+C to copy link, Control+Shift+Right Arrow to 
highlight text, Control+K, Control+V, Enter. 
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Step Five: Header Rows in Tables 

Table data cells have a relationship with their row and/or column headers. 
To ensure all individuals can perceive this information, assign a header 
row.  

Table Header in Word 

To assign a table header in Microsoft Word: 

1. Insert a table in the location desired. 
2. Highlight the top row. 
3. Right click, select Table Properties 
4. In the pop-up dialogue box, navigate to the Row tab. 
5. Check the box Repeat as Header Row at the top of each page. 
6. Select Ok. 

Via Keyboard: Alt+N, T, I, enter number of columns, Tab, then enter 
number of rows, press Enter. 

  

https://support.microsoft.com/en-us/office/insert-a-table-a138f745-73ef-4879-b99a-2f3d38be612a#:%7E:text=For%20a%20basic%20table%2C%20click,convert%20it%20to%20a%20table.


13 

Table Header in Excel 

To assign a table header in Microsoft Excel: 

1. Select all data cells. 
2. Go to Insert tab, in the Tables group, click Table. 
3. In the Create Table dialogue box, check My Table has Headers. 

Next, create a name range for the header cells. This step is important to 
help screen readers identify and navigate cells.  

1. Place focus on header row and/or column. 
2. In the Formulas tab, Defined Names group, select Define Name. 
3. In the New Name dialogue box, under Name, enter a formula 

containing the following (include periods). 
HeaderRegionTableNumber.FirstCellCoordinate. 
LastCellCoordinate.SheetNumber 

a. HeaderRegion: This will either be “ColumnTitle”, “RowTitle”, 
or “TitleRegion”. Enter: 

ColumnTitle – if the table contains column headers only. 
RowTitle – if the table contains row headers only. 
TitleRegion – if the table contains both column and row 
headers. 

b. TableNumber – Every table is assigned a table number by 
default. For example, the first table created is 1, second is 2, 
etc. Input that number here. 

c. FirstCellCoordinate – This is the coordinate of the first cell in 
the table. 

d. LastCellCoordinate – This is the coordinate of the last cell in 
the table. 

e. SheetNumber – Each sheet is assigned a number, starting 
with 1. Enter that number here.  

4. Click Ok.  
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Via Keyboard:  

1. Create a table: Navigate to a data cell, Control+A, Control+T, press 
Enter. 

2. Create name range: Control+G, Tab, Down Arrow (until you get to 
the desired table), Enter, Up Arrow, Alt, M, M, D, type formula, press 
Enter. 

The following are examples of correct name range implementation. 

Example 1: Table with Column Headers  

The first sheet in an Excel file has a table displaying office supply orders. 
The table contains four columns five rows (A1:D5). In the New Name 
dialogue box, the Name field has the formula: ColumnTitle1.A1.D5.1 

 

 

Example 2: Table with both Row and Column Headers 

The second sheet in the Excel file has a table displaying Office Hours. 
This table has six columns, six rows (A1:F6). In the New Name dialogue 
box, the Name field has the formula: TitleRegion2.A1.F6.2 
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Example 3: Table with Row Headers 

The last sheet in the Excel file has a table displaying Today’s Menu. The 
table has two columns three rows (A1:B3). In the New Name dialogue 
box, the Name field has the formula: RowTitle3.A1.B3.3 

 

Additional Table Tips 

• Always construct simple tables. 
• Use one row for the Header. 
• Never merge or split cells. 
• Avoid blank cells, rows, and/or columns. 

Excel Only 

• Use unique sheet names. 
• Place focus on the cell A1 or first cell with content. 
• Provide descriptive Table Names.  
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Step Six: Built-in Styles & Designs 

Microsoft Word 

Microsoft Word has built in styles to format and organize content. These 
styles can be applied to Headings, Lists, etc. The Styles are in the Home 
tab or via Alt+Control+Shift+S. 

 

Heading Style 

Changing text appearance, such as applying bold or using all caps, does 
not make text into a heading. You need to assign heading styles. To apply 
a Heading Style: 

1. Select your text. 
2. Go to the Styles Pane. 
3. Select the desired heading level. 

Via Keyboard: Control+Shift+Right Arrow, Alt+Control+Shift+S.  
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Heading Order 

Microsoft Word goes up to nine heading levels and Adobe Acrobat six. 
You are not required to use all heading levels, but they do have to follow a 
sequential order. This means the heading introducing the big idea will be 
a Heading 1. Major subsections of the big idea will be a Heading 2. Major 
subsections of the 2 will be 3. You cannot start with a Heading 1 then 
jump to a 3 or start a document with a Heading 6. 

Table of Contents 

Applying headings has another benefit. A Table of Contents can be added 
to the document using the headings. Think of this as an outline that 
makes it easy to locate content and navigate to the desired sections. To 
add a Table of Contents: 

1. Place cursor in document. 
2. Go to References tab. 
3. Click Table of Contents. 
4. Select a style. 

Via Keyboard: Alt, S, T, Down Arrow to cycle through options. 

List Formatting  

Lists made with repeated use of the Tab key or Spacebar are not true 
lists. A correct list format allows users to navigate between items and 
move in and out of lists. To add a List: 

1. Place cursor in document. 
2. Navigate to the Home tab, Paragraph Group. 
3. Select one of the list controls. 

Via Keyboard: Alt, H, then either U for Unordered list (bulleted list), N for 
Numbered list, or M for more options for the list.   
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Indent & Line Spacing 

When the Tab key or Spacebar are used to visually create space between 
content, the screen reader reads these as “blank” to a user. Having one or 
two blanks is not an issue but hearing one after every paragraph or 
consecutively can be distracting and confusing. For a better reading 
experience, use the Indent and Line Spacing features. To access: 

1. In the Home tab, under Paragraph group, select: 
a. Decrease or Increase Indent 
b. Paragraph Spacing  

Via Keyboard: Alt, H, then either AO to decrease or AI to increase indent. 
Alt, H, K, down arrow to navigate the spacing options, press Enter to 
select.  
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Text Boxes 

Do not use Text Boxes as they are inaccessible. A screen reader will not 
read the contents of Text Boxes until it reaches the end of the document.  

To emphasize text, here is an alternative: 

1. Select the text. 
2. In the Home tab, Paragraph group, go to Borders. 
3. Select Outside Borders. 
4. Next, choose a fill color. In the Home tab, Paragraph group, go to 

Shading. 
5. Select desired color. (Ensure colors are accessible.) 

Via Keyboard: 

1. To add the border: Control+Shift+Right Arrow, Alt, H, B, S.  
2. To add shading: Alt, H, H, Arrow to desired color. 

 

Since screen readers do not announce text color, include clues so users 
know what the text is for, and when it begins and ends. Words like Case 
Study at the beginning and End Case Study at the end are beneficial.   
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Microsoft PowerPoint 

Slide Layout 

PowerPoint contains a collection of pre-set slide layouts. To ensure the 
slideshow is accessible, use these pre-set templates. To apply: 

1. In the Home tab, choose New Slide. 
2. Pick a layout.  

Design Themes 

PowerPoint offers built-in designs, however, not all are accessible. When 
selecting a built-in design theme, ensure it meets accessible design 
considerations. To apply a design theme: 

1. Go to the Design tab. 
2. In the Themes group, expand the drop down menu. 
3. Select design. 

From Design tab, navigate to Variants to adjust color and font choices. 

Via Keyboard: 

1. To access Design Themes: Alt, G, H. 
2. To access Variants: Alt, G, V, then either C for Color or F for font. 
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Additional PowerPoint Considerations 

Usability of PowerPoint 

PowerPoint can be an effective tool for presentations but is not the best 
file format when considering accessibility and usability. A more accessible 
way of distributing PowerPoint slideshows is by exporting them into either 
Portable Document Format (PDF) or HyperText Markup Language 
(HTML). These formats can be made accessible, and they are smaller file 
sizes for downloading.  

Animations and Transitions 

Avoid animation and automatic slide transitions since they: 

• Can be distracting
• Can cause screen readers to re-read slides
• Can read parts of the slide out of order
• May not give users enough time to read slide content

Data Tables 

Tables can be added to PowerPoint but are not accessible. If data will be 
presented in tables, provide text descriptions, or consider saving the 
presentation as a PDF then adding accessibility information in Adobe 
Acrobat Pro. 

Embedded Multimedia 

Ensure embedded videos are captioned and that the player controls are 
accessible. If an audio file is embedded, ensure a transcript is included. 

Text Boxes 

We recommend never adding Text Boxes. If you use Text Boxes, check 
the reading order. Text Boxes are always read by a screen reader after all 
Content Placeholders. Content Placeholders are the containers that 
display slide content. Slides with more than one Text Box complicate the 
reading order. Additionally, text placed in Text Boxes will not appear in the 
Outline view. This complicates the conversion from PowerPoint to HTML.  



22 

Step Seven: Accessibility Testing 

Both Microsoft Office and Adobe Acrobat have built in accessibility 
checkers. These can be used to check your document’s accessibility. 
However, do not rely on machine testing alone. 

In addition, incorporate human testing. Use a screen reader to listen to the 
document. Preferably, develop an accessibility testing team of individuals 
experienced at using Assistive Technology.  

Microsoft Office 

To access the Accessibility Checker in Microsoft Word: 

1. Go to File, Info.
2. Check for Issues.
3. Check Accessibility.

Via Keyboard: Alt, F, I, I, A 
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Adobe Acrobat Pro 

To access the Accessibility Checker in Adobe Acrobat Pro, first add the 
Accessibility Tool. 

1. Go to View. 
2. Select Tools. 
3. Click Accessibility. 
4. Select Open. 

Next: 

1. Select Accessibility Check. 
2. In the Accessibility Checker Options dialogue box, select Start 

Checking. 

Via Keyboard: 

1. To open the Accessibility Tool: Alt, V, T, arrow down to Accessibility, 
press Enter twice. 

2. To run an Accessibility Check: F6, arrow down to Accessibility 
Check, press Enter twice, F6 until you hear “Document” along with 
the number of issues present for that category. 
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Resources  

• Adobe Acrobat Accessibility Series (videos) 
(https://tinyurl.com/AcrobatAccessibilitySeries)  

 
(https://www.youtube.com/watch?v=1tgP82MvXzk&list=PLdcwkELts-
sz8H1-6gijjfC8l8Br8w3sf) 

 
(https://webaim.org/resources/contrastchecker/) 

 
(https://www.tpgi.com/color-contrast-checker/) 

 
(https://tinyurl.com/DGS-ManagementMemo0308) 

 
(https://publicaccessstorage.blob.core.usgovcloudapi.net/publicsitefiles
/DOR%20Documents/Disability%20Access%20Services/DOR%20Doc
ument%20Accessibility%20Standards%20June%202019.pdf) 

  
(https://www.dor.ca.gov/Home/WebAccessibilityToolkit) 

 
(https://www.youtube.com/watch?v=dzpj5CwyYOU) 

 
(http://www.freedomscientific.com/doccenter/archives/Training/acce
ssible-forms-in-word.htm) 

 
(https://www.hhs.gov/web/section-508/accessibility-
checklists/index.html)  

• California Department of Social Services Accessibility Videos

• Color Checking Tools 

o Web Accessibility in Mind Contrast Checker

o The Paciello Group Colour Contrast Analyser

• Department of General Services Management Memo 03-08

• Department of Rehabilitation Accessibility Standards

• DOR Web Accessibility Toolkit

• Forms 

o Governor’s Committee on People with Disabilities (video)

o Creating Accessible Forms in Microsoft Word

• Health and Human Services Accessibility Conformance Checklists

https://experienceleague.adobe.com/docs/document-cloud-learn/acrobat-learning/advanced-tasks/accessibility-series/accessibility-series.html?
https://www.youtube.com/watch?v=1tgP82MvXzk&list=PLdcwkELts-sz8H1-6gijjfC8l8Br8w3sf
https://webaim.org/resources/contrastchecker/
https://www.tpgi.com/color-contrast-checker/
https://www.dgs.ca.gov/-/media/Divisions/OTPFS/Memos/MM03_08.pdf?la=en&hash=234F6CD63FD6A936E25FF133AF396FDE1E0EEFB8
https://publicaccessstorage.blob.core.usgovcloudapi.net/publicsitefiles/DOR%20Documents/Disability%20Access%20Services/DOR%20Document%20Accessibility%20Standards%20June%202019.pdf
https://www.dor.ca.gov/Home/WebAccessibilityToolkit
https://www.youtube.com/watch?v=dzpj5CwyYOU
http://www.freedomscientific.com/doccenter/archives/Training/accessible-forms-in-word.htm
https://www.hhs.gov/web/section-508/accessibility-checklists/index.html
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• Microsoft: 
o Create Accessible Office Documents 

(https://support.microsoft.com/en-us/office/create-accessible-office-
documents-868ecfcd-4f00-4224-b881-a65537a7c155) 

o Accessibility Training videos 
(https://tinyurl.com/MS-AccessibilityVideos) 

 
(https://www.microsoft.com/en-us/Accessibility/disability-answer-
desk?activetab=contact-pivot%3aprimaryr8) 

 
(https://tinyurl.com/OutlookAccessibility) 

o Microsoft Disability Answer Desk

o Outlook Accessibility

• Office of the Governor, State of Texas 
(http://gov.texas.gov/disabilities/accessibledocs) 

 
(https://www.section508.gov/create/) 

 
(https://www.w3.org/WAI/WCAG21/quickref/) 

 
(https://www.w3.org/WAI/WCAG21/Understanding/non-text-
content.html) 

(https://www.w3.org/WAI/WCAG21/Understanding/info-and-
relationships.html) 

 
(https://www.w3.org/WAI/WCAG21/Understanding/use-of-
color.html) 

 
(https://www.w3.org/WAI/WCAG21/Understanding/contrast-
minimum.html) 

• Section 508 Create Accessible Digital Content

• Web Content Accessibility Guidelines (WCAG) Quick Reference

o Specific success criteria referenced in this resource: 
 1.1.1 Non-text Content

 1.3.1 Information and Relationships 

 1.4.1 Use of Color

 1.4.3 Contrast (Minimum)

 1.4.11 Non-text Contrast 
(https://www.w3.org/WAI/WCAG21/Understanding/non-text-
contrast.html)  

https://support.microsoft.com/en-us/office/create-accessible-office-documents-868ecfcd-4f00-4224-b881-a65537a7c155
https://support.microsoft.com/en-us/office/accessibility-video-training-71572a1d-5656-4e01-8fce-53e35c3caaf4?ui=en-us&rs=en-us&ad=us
https://www.microsoft.com/en-us/Accessibility/disability-answer-desk?activetab=contact-pivot%3aprimaryr8
https://support.microsoft.com/en-us/office/make-your-outlook-email-accessible-to-people-with-disabilities-71ce71f4-7b15-4b7a-a2e3-cf91721bbacb#:%7E:text=In%20Outlook%2C%20you%20can%20define,manually%20launch%20the%20Accessibility%20Checker.
http://gov.texas.gov/disabilities/accessibledocs
https://www.section508.gov/create/
https://www.w3.org/WAI/WCAG21/quickref/
https://www.w3.org/WAI/WCAG21/Understanding/non-text-content.html
https://www.w3.org/WAI/WCAG21/Understanding/info-and-relationships.html
https://www.w3.org/WAI/WCAG21/Understanding/info-and-relationships.html
https://www.w3.org/WAI/WCAG21/Understanding/use-of-color.html
https://www.w3.org/WAI/WCAG21/Understanding/contrast-minimum.html
https://www.w3.org/WAI/WCAG21/Understanding/non-text-contrast.html
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 2.4.4 Link Purpose 
(https://www.w3.org/WAI/WCAG21/Understanding/link-purpose-
in-context.html) 

 2.4.6 Headings and Labels  

 

(https://www.w3.org/WAI/WCAG21/Understanding/headings-
and-labels.html) 

This document may be reproduced without change and in its entirety for 
redistribution purposes without prior permission from DAS. (July 2023) 

https://www.w3.org/WAI/WCAG21/Understanding/link-purpose-in-context.html
https://www.w3.org/WAI/WCAG21/Understanding/headings-and-labels.html
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